Modification de l'ordre des commentaires après édition

  • Auteur
    Articles
  • #22351

    druidesse
    Membre

    Bonjour,

    J’ai remarqué qu’en éditant des commentaires, ceux-ci se déplacent dans l’ordre d’apparition (anti-chronologique). Cela se passe comme la date d’édition devenait prioritaire par rapport à la date de parution (alors que c’est toujours cette dernière qui est affichée).

    Est-il possible d’empêcher cela ? J’ai essayé en modifiant la date de parution (cadre en haut à droite « Envoyé le »), mais cela ne fonctionne pas. Il indique bien la date modifiée, mais le classement du commentaire reste cohérent avec la date de modification.

    Existe-t-il un réglage permettant d’afficher les commentaires selon la date de parution sans qu’un édition ultérieur vienne changer l’ordre des commentaire ?

    Merci pour votre aide m(_ _)m

    L'adresse du blog concerné est gewissae.wordpress.com.

    #22658

    airodyssey
    Modérateur

    Bonjour. Première fois que j’entends parler de cela. Il existe bien un réglage dans Réglages > Discussion pour modifier l’ordre des commentaires (chrono ou antichrono).

    #22670

    druidesse
    Membre

    Bonjour, votre intervention m’a fait penser à une bidouille. J’ai changé le reglage et visionné une des pages où le problème est apparu. Puis j’ai rétabli le réglage. Malheureusement, le « bug » subsisite dans les 2 cas. Le commentaire édité n’est plus à sa place… :/

    #22675

    airodyssey
    Modérateur

    Quelle page (http://)? Et quel commentaire? J’aimerais comprendre, mais pour cela, il faudrait que je puisse voir le problème en contexte.

    #22678

    druidesse
    Membre

    par exemple cette page : http://gewissae.wordpress.com/2009/03/28/falaises-lumiere/

    Comme on le voit sur les dates, le 1° commentaire (le mien) se situe entre l’actuel 2° et le 3°. A l’époque l’ordre chronologique était correct (mon messge était bien le 2° (et l’actuel 2° était le 1°) Il s’est déplacé en 1° place après avoir été édité récemment.

    #22690

    airodyssey
    Modérateur

    Pourriez-vous aller à Réglages > Discussion et me dire SVP ce qui est indiqué à l’option « Activer les commentaires imbriqués jusqu’à … »?

    (À part de cela, je suis à court d’idées, désolé.)

    #22694

    druidesse
    Membre

    ils sont imbriqués jusqu’à 2 niveaux. Mais les réponses ont été faites normalement, donc c’est comme si l’option ne servait pas (je pense).

    J’ai essayer de reproduire le problème avec un article test et une réponse / heure. Mais ça n’a pas marché : le commentaire édité reste à sa place. Il se « déplace » normalement si je change la date du commentaire.

    La seule chose qui est différente c’est que le commentaire édité date de 3 ans. Peut-être un problème de version ?

    #22695

    airodyssey
    Modérateur

    Désolé, je pensais vous avoir répondu.

    Je ne crois pas que ce soit un problème de « version ». WordPress.com fonctionne avec la version la plus récente en tout temps.

    Si vous n’avez toujours pas réglé la situation, je vous invite à écrire au soutien à support@wordpress.com

Le sujet ‘Modification de l'ordre des commentaires après édition’ est fermé aux nouvelles réponses.